Processing Ajax...

Title
Close Dialog

Message

Confirm
Close Dialog

Confirm
Close Dialog

Things I copy often don't paste until I click the "Clipboard Manager" - anyone else?

User Image
oatleyd
7 discussion posts
I've been using ClipboardFusion for years. I just noticed this behavior on my new laptop, so it's been going on for a few months now.

I select text, hit Ctrl-C (or right-click and choose copy, or whatever -- that doesn't seem to matter), then when I hit Ctrl-V (or whatever) to paste, nothing happens.

However, I do see what I copied in the Clipboard Manager. And if I click it, it does paste. If I hit Ctrl-V after that, it pastes again.

It's as if ClipboardFusion saw me do the copy, and kept a copy itself, but didn't store it on the clipboard.

If I exit ClipboardFusion, copy/paste works as expected.

Is this happening to anyone else? Or is just a "me" thing?

It's crazy-making!

Windows 10 (10.0.19044.0)
ClipboardFusion 5.9.1

Dave
Jul 14, 2022  • #1
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Dave,

Could you send me over a debug log? Here are the steps:
  • On the ClipboardFusion Settings > Troubleshooting tab, change the Logging drop-down to "L1: Log Minimal" and click Apply
  • Reproduce the issue and note the time so we'll know where to check in the log file
  • Click the "Export Info to File" button on the Settings > Troubleshooting tab
  • Reply with the file attached
  • Disable debug logging after sending the log

Thanks!
Jul 14, 2022  • #2
User Image
oatleyd
7 discussion posts
Thank you! It happened just now with the text INC02867909. I copied it, but when I tried to paste it, it didn't paste. Then I clicked on it in Clipboard Manager and it did.

I dumped out the logs. The file is attached.
• Attachment [protected]: ClipboardFusionDebugInfo.zip [67,834 bytes]
Jul 15, 2022  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Dave,

Thanks for sending that over. When the issue happens and you aren't able to paste with Ctrl+V, if you exit ClipboardFusion, are you then able to paste? Or do you have to have re-copy the item first?

Thanks!
Jul 15, 2022  • #4
User Image
oatleyd
7 discussion posts
Good morning! I just had it happen, so I closed ClipboardFusion and tried to paste. No joy - nothing was on the clipboard.

Then I reopened ClipboardFusion and saw what I'd copied still on the Clipboard Manager. I clicked it, and the value pasted.

Once I've clicked Clipboard Manager, the value is placed on the clipboard. So subsequent attempts to paste will work.
Jul 18, 2022  • #5
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Interesting, can you update to our latest beta (https://www.clipboardfusion.com/Download/Beta/) and then send me over a backup of your settings? You can grab them from the ClipboardFusion Settings > Options tab.

Thanks!
Jul 19, 2022  • #6
User Image
oatleyd
7 discussion posts
I updated and everything is running as expected. I'll keep an eye on it and let you know if it does the same thing.

I'll also attach the settings. I pulled them before the update too, in case you need those. This is just the "after" set.

Thanks for all your help!
• Attachment [protected]: ClipboardFusion Backup (2022-07-19 @ 14-57, 5.9.99.103, NW242527, SettingsWindow).db [5,488,640 bytes]
Jul 19, 2022  • #7
User Image
oatleyd
7 discussion posts
The issue occurred again this morning while running the beta, so I turned logging back on. When it happened a second time, I saved the log.
I also grabbed a screen shot showing that the clipboard manager knows I copied something (in this case, the text "icfile") but the Windows clipboard itself is empty. You can see that from the fact that the "paste" option is grayed out in Notepad.
Both the log and the screenshot are attached.
What can I do from here?
• Attachment [protected]: ClipboardFusion-nothing-on-clipboard-at-all.PNG [28,830 bytes]
• Attachment [protected]: ClipboardFusionDebugInfo-20220720.zip [143,308 bytes]
Jul 20, 2022 (modified Jul 20, 2022)  • #8
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Sorry that's not quite the file I'm looking for. When you export your settings, it should create two files, a .db file (the one you sent over) and a .reg file. I'm looking for the .reg file.

Thanks!
Jul 20, 2022 (modified Jul 20, 2022)  • #9
User Image
oatleyd
7 discussion posts
Oops, my mistake! The reg/db files are attached.
• Attachment [protected]: ClipboardFusion Backup (2022-07-20 @ 12-26, 5.9.99.103, NW242527, SettingsWindow).db [901,120 bytes]
• Attachment [protected]: ClipboardFusion Backup (2022-07-20 @ 12-26, 5.9.99.103, NW242527, SettingsWindow).reg [11,576 bytes]
Jul 20, 2022  • #10
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Thanks for sending that over. I was testing your settings on my end but I couldn't seem to reproduce this. If you disable the two triggers in the ClipboardFusion Settings > Triggers tab, does that make any difference?

Thanks!
Jul 28, 2022  • #11
User Image
oatleyd
7 discussion posts
Sorry I disappeared for awhile, but I've been waiting for this to happen again and it hasn't! Maybe the beta eliminated the problem? I know I saw it after the installation of the beta, but I may not have rebooted after the install.

At this point, I'm not seeing the issue anymore. Yay? I wish I knew what happened, but at least it's not happening anymore!

So yes -- YAY!

Thanks for your help!

Dave
Aug 1, 2022  • #12
Was this helpful?  Login to Vote(-)  Login to Vote(-)