Title

Message

Confirm

Want to earn a free ClipboardFusion Pro license? We're looking for ClipboardFusion translators!
<< DiscussionsReply

Copy with formatting, paste as plain text

Avatar from Gravatar.com
Jacob Munson
6 discussion posts
I am new to ClipboardFusion. What I would like is to always copy text keeping formatting in place (say bold, italics, etc). If I paste it would paste the formatted text by default. But I'd like to use a different hotkey to paste as plain text. I found the Trigger that scrubs text on copy and disabled that. So I have the first half working...copy formated and then paste formatted. But now I'd like to setup a hotkey that would scrub the text on paste.

I have searched the settings, the Macros, and this Discussion board and can't find out how to do this. What am I missing?
Jun 21, 2019 (modified Jun 21, 2019)  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
What I usually do is enable the Triggers, but set the Trigger Command to the "double-copy" option, so that it only scrubs if I hit Ctrl + C twice in quick succession.

Another thing you can do is set the Trigger Command to disabled, and then set a hotkey on the "Run Triggers Now" function (Settings > HotKeys tab).

Hope that helps!
Jun 21, 2019  • #2
Avatar from Gravatar.com
Jacob Munson
6 discussion posts
I actually have it setup like your second suggestion, but I just realized I didn't understand what scrubbing does. It does not remove all formatting leaving just plain text. That is what I want...what can I do to paste with just plain text (no bold, not links, no fonts, no color, etc.)?
Jun 21, 2019  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
The scrubbing should be removing the formatting. Is there still a "Scrub Text" action in the Trigger rule?
Jun 21, 2019  • #4
Avatar from Gravatar.com
Jacob Munson
6 discussion posts
Yes, but just did some testing and the scrubbing doesn't work when the trigger is disabled. However, enabling it also runs the trigger when I copy text, which is not what I want.
Jun 21, 2019  • #5
Avatar from Gravatar.com
Jacob Munson
6 discussion posts
Yep, I did some more testing to verify. If I disable the trigger, copy some formatted text and paste, it keeps the formatting. If I then enable the trigger, paste the same formatted text using my hotkey, it scrubs the text. But then if I copy formatted text again it also scrubs. I can't find a way to copy formatted and then paste scrubbed using a hotkey.
Jun 21, 2019  • #6
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Are you disabling the Trigger rule itself, or setting the "Trigger Command Setting" drop-down to "Disabled" while leaving the rule itself enabled?
Jun 24, 2019  • #7
Avatar from Gravatar.com
Jacob Munson
6 discussion posts
Genius! I had disabled the trigger command itself. I just tried enabling that and then disabling the Trigger Command Setting and now it does exactly what I wanted. Thanks!
Jun 24, 2019  • #8
Keith Lammers (BFS)'s profile on WallpaperFusion.com
No worries, glad to hear it!
Jun 24, 2019  • #9
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply