Title

Message

Confirm

<< DiscussionsReply

use of CF caused me to need to reload AHK text expander Scripts every time

Tim Rose33954
4 discussion posts
I use AHK extensively, and have recently started to use Clipboard Fusion. I have noticed that when I paste from the Clipboard my text expander hotkeys stop working. Other Scripts continue to work fine (As far as I know). The text expansion is simple like this:

Code


This causes a string like "aTm" turn automagically into "At the moment".
I have the Pro Personal license so if I knew C# I could run the macro to reload the Scripts automatically (Ctrl-Alt-A in my case) but I would rather have a more elegant solution.
11 days ago  • #1
Tim Rose33954
4 discussion posts
As long as I don't actually paste anything using CF my text expander Scripts work fine. As soon as I use CF to paste anything, the shortcuts stop working until I reload the Scripts again. They're still running; they just need to be reloaded. If I don't reload them the text expansion will never work.
I have:
1. Tried the Beta version
2. Upgraded AHK to the most recent version
11 days ago (modified 11 days ago)  • #2
Tim Rose33954
4 discussion posts
OK. Update/Workaround:
I had been loading the 2 expand text Scripts separately, but doing so from inside my main script. i.e. when I run the main script it also loaded the expand text Scripts but they appeared as separate apps in Task manager...
By making them Included files instead of stand-alone files I seem to have fixed the problem. No idea why, but now I can move forward.
Thanks Owen Muhlethaler for your quick reply.
11 days ago  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Hi Tim,

Interesting, glad to hear it's working! If the issue comes back just let me know.

Thanks!
11 days ago  • #4
Was this helpful?    
<< DiscussionsReply