Title

Message

Confirm

<< DiscussionsReply

Running macros does not work from the clipboard manager

A Sen
17 discussion posts
Hello, I have a few macros defined that prompt for a string. If I try and run these from the macros tab in the clipboard manager, nothing happens. If I right-click on the system tray icon and choose macros and run them from there then it works every time. I'm on 6.0 beta 1. Thank you.
29 days ago (modified 1 day ago)  • #1
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Could you send me over one of those macros so I can test it out?

Thanks!
28 days ago  • #2
A Sen
17 discussion posts
Sure. This is one. The dialog box never appears when run from the clipboard manager.
• Attachment [protected]: macro.txt [615 bytes]
27 days ago  • #3
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Thanks for sending that over. I tested it out on my end and it seemed to work. Can you try updating to our latest beta and see if the issue persists? We've fixed up a few script issues there.

Thanks!
27 days ago  • #4
A Sen
17 discussion posts
Same problem with beta 2. I'm not massively bothered because I can still run macros by right-clicking on the system tray icon. It's just a minor annoyance.
26 days ago  • #5
Owen Muhlethaler (BFS)'s profile on WallpaperFusion.com
Strange, could you send me over a debug log? Here are the steps:

  • On the ClipboardFusion Settings > Troubleshooting tab, change the Logging drop-down to "L1: Log Minimal" and click Apply
  • Reproduce the issue and note the time so we'll know where to check in the log file
  • Click the "Export Info to File" button on the Settings > Troubleshooting tab
  • Reply with the file attached
  • Disable debug logging after sending the log

Thanks!
26 days ago  • #6
A Sen
17 discussion posts
Hi Owen, sorry for the delayed reply. I think I have found the culprit. If 'Auto-paste on Clipboard manager selection' is not checked then the problem happens. If it is checked then I can run this macro from the macros tab when the clipboard history is up. It works from the Windows system tray regardless of this setting.
1 day ago  • #7
Was this helpful?    
<< DiscussionsReply