Title

Message

Confirm

Want to earn a free ClipboardFusion Pro license? We're looking for ClipboardFusion translators!
<< DiscussionsReply

Items not being added to history

Avatar from Gravatar.com
classicboss302
17 discussion posts
At times, I notice that items that I copy won't be added to the history. Below is what I see in the logs when this happens. If I close and reopen ClipboardFusion, then items are added to the history again. I haven't figured out yet what exactly is triggering the issue.

2019/05/30 09:02:51.5366##_##INFO:L1##_##clipboardfusion.exe:8936##_##frmMain:ProcessClipboardContents##_##-##_##Path: c:\program files (x86)\google\chrome\application\chrome.exe##_##-
2019/05/30 09:02:51.5406##_##FAIL:L1##_##clipboardfusion.exe:8936##_##ClipboardManager:Add##_##-##_##Object reference not set to an instance of an object.##_##-

As a side note, I see this message in the logs when I start ClipboardFusion.

2019/05/30 09:04:14.4509##_##FAIL:L1##_##clipboardfusion.exe:6036##_##BFPublicData:CurrentDomain_AssemblyResolve##_##-##_##Assembly: ClipboardFusion.resources, Version=5.6.0.0, Culture=en-US, PublicKeyToken=null, Unable to find assembly: ClipboardFusion.resources, Version=5.6.0.0, Culture=en-US, PublicKeyToken=null##_##-
May 30, 2019  • #1
Keith Lammers (BFS)'s profile on WallpaperFusion.com
We've run into this in the past and it seems to be related to an issue with an item currently in the history. If you're ok with sharing your clipboard history with us, could you backup your settings (Settings > Options > Export) and send us both files using "Help > Support Request" in the Settings window?

If not, if you just clear the history it should resolve this issue.
May 30, 2019  • #2
Avatar from Gravatar.com
classicboss302
17 discussion posts
The next time I notice it happening, I will check my history and see about sending it.
May 30, 2019  • #3
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Sounds good, thanks!
May 30, 2019  • #4
Avatar from Gravatar.com
classicboss302
17 discussion posts
I was finally able to reproduce this issue. If I am using Putty for SSH, and then select Whitespace, that will cause subsequent copies not to be added to the clipboard history. Even though copied text will not be added, copying files out of File Explorer will be added. And if it is anything but Whitespace, items will still be added.
• Attachment: ExplorerCopy.jpg [96,473 bytes]
ExplorerCopy.jpg
ExplorerCopy.jpg
• Attachment: SSHCopy.jpg [85,450 bytes]
SSHCopy.jpg
SSHCopy.jpg
17 days ago  • #5
Keith Lammers (BFS)'s profile on WallpaperFusion.com
So you're copying the whitespace from PuTTY, then trying to paste it back into PuTTY? And after that, you can't copy any text from any program to the history any more?
16 days ago  • #6
Avatar from Gravatar.com
classicboss302
17 discussion posts
Selecting something in Putty copies it. There is no need to deliberately copy text. So if some whitespace gets selected it will be copied.
16 days ago  • #7
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, so you can reproduce it like this?
  • Select some empty space in PuTTY, "[Whitespace]" entry gets added to the history.
  • Select some other text in PuTTY, it doesn't get added to the history?
15 days ago  • #8
Avatar from Gravatar.com
classicboss302
17 discussion posts
Mostly correct. Nothing gets added to the history from other applications as well, except for copying files in File Explorer for some reason.
15 days ago  • #9
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, strange! When I test that out here, it works for me without issues. Could you send over a debug log?

Could you send me a debug log?
  • On the ClipboardFusion Settings > Troubleshooting tab, change the Logging drop-down to "L1: Log Minimal" and click Apply
  • Reproduce the issue and note the time so we'll know where to check in the log file
  • Click the "Export Info to File" button on the Settings > Troubleshooting tab
  • Reply with the file attached
  • Disable debug logging after sending the log
15 days ago  • #10
Avatar from Gravatar.com
classicboss302
17 discussion posts
Here you go. I have mRemoteNG as a wrapper around Putty. I went for the complete logging as it didn't seem like minimal was giving a lot of detail when I was looking through it. I tried copying 3 times. If you search for puttyng.exe, the second one corresponds to the whitespace and the third one did not work.

Here is the exception being thrown in the memory dump as well.

System.NullReferenceException
HResult=0x80004003
Message=Object reference not set to an instance of an object.
Source=System.Windows.Forms
StackTrace:
at System.Windows.Forms.DataObject.SaveDataToHandle(Object data, String format, STGMEDIUM& medium)
• Attachment [protected]: ClipboardFusionDebugInfo-All.zip [16,656 bytes]
15 days ago  • #11
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, interesting! If you use PuTTY standalone, does the same thing happen?
15 days ago  • #12
Avatar from Gravatar.com
classicboss302
17 discussion posts
Same thing with Putty on its own.
15 days ago  • #13
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Ok, interesting! I wonder what's different between your machine and mine. Could you backup your settings (Settings > Options > Export) and send them over?
15 days ago  • #14
Avatar from Gravatar.com
classicboss302
17 discussion posts
Here you go.
• Attachment [protected]: ClipboardFusion Backup (2019-08-09 @ 07-27, 5.6.0.0, CSHERIDAN-T480).reg [12,308 bytes]
15 days ago  • #15
Keith Lammers (BFS)'s profile on WallpaperFusion.com
Thanks! I was able to reproduce this issue using your settings and we've added it to our list to fix up
14 days ago  • #16
Was this helpful?  Login to Vote  Login to Vote
<< DiscussionsReply